knownports / Patterns
Port numbers that cite an RFC
178 port numbers cite at least one RFC beyond the general registry and transport documents (RFC 6335, RFC 9260 and RFC 4340). Between them they cite 168 different RFCs. The most cited is RFC 5811, “SCTP-Based Transport Mapping Layer (TML) for the Forwarding and Control Element Separation (ForCES) Protocol”, on 3 numbers. 5 cited RFCs have since been obsoleted by a later document: RFC 1568, RFC 3501, RFC 3547, RFC 3576 and RFC 3588.
| Port | Service | RFCs and titles |
|---|---|---|
| 13 | daytime | RFC 867 Daytime Protocol |
| 21 | ftp | RFC 959 File Transfer Protocol |
| 22 | ssh | RFC 4251 The Secure Shell (SSH) Protocol Architecture |
| 23 | telnet | RFC 854 Telnet Protocol Specification |
| 67 | bootps | RFC 951 Bootstrap Protocol |
| 80 | httpwww | RFC 9110 HTTP Semantics |
| 88 | kerberos | RFC 4120 The Kerberos Network Authentication Service (V5) |
| 119 | nntp | RFC 3977 Network News Transfer Protocol (NNTP) |
| 123 | ntp | RFC 5905 Network Time Protocol Version 4: Protocol and Algorithms Specification |
| 143 | imap | RFC 3501 INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1 RFC 9051 Internet Message Access Protocol (IMAP) - Version 4rev2 |
| 269 | manet | RFC 5498 IANA Allocations for Mobile Ad Hoc Network (MANET) Protocols |
| 270 | gist | RFC 5971 GIST: General Internet Signalling Transport |
| 271 | pt-tls | RFC 6876 A Posture Transport Protocol over TLS (PT-TLS) |
| 300 | tacacss | RFC 9887 Terminal Access Controller Access-Control System Plus (TACACS+) over TLS 1.3 |
| 323 | rpki-rtr | RFC 6810 The Resource Public Key Infrastructure (RPKI) to Router Protocol |
| 324 | rpki-rtr-tls | RFC 6810 The Resource Public Key Infrastructure (RPKI) to Router Protocol |
| 350 | matip-type-a | RFC 2351 Mapping of Airline Reservation, Ticketing, and Messaging Traffic over IP |
| 351 | matip-type-b | RFC 2351 Mapping of Airline Reservation, Ticketing, and Messaging Traffic over IP |
| 433 | nnsp | RFC 3977 Network News Transfer Protocol (NNTP) |
| 443 | https | RFC 9110 HTTP Semantics |
| 444 | snpp | RFC 1568 Simple Network Paging Protocol - Version 1(b) |
| 465 | submissions | RFC 8314 Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and Access |
| 514 | syslog | RFC 5426 Transmission of Syslog Messages over UDP |
| 546 | dhcpv6-client | RFC 9915 Dynamic Host Configuration Protocol for IPv6 (DHCPv6) |
| 547 | dhcpv6-server | RFC 5460 DHCPv6 Bulk Leasequery RFC 9915 Dynamic Host Configuration Protocol for IPv6 (DHCPv6) |
| 551 | cybercash | RFC 1898 CyberCash Credit Card Protocol Version 0.8 |
| 563 | nntps | RFC 4642 Using Transport Layer Security (TLS) with Network News Transfer Protocol (NNTP) |
| 587 | submission | RFC 6409 Message Submission for Mail |
| 601 | syslog-conn | RFC 3195 Reliable Delivery for syslog |
| 602 | xmlrpc-beep | RFC 3529 Using Extensible Markup Language-Remote Procedure Calling (XML-RPC) in Blocks Extensible Exchange Protocol (BEEP) |
| 603 | idxp | RFC 4767 The Intrusion Detection Exchange Protocol (IDXP) |
| 604 | tunnel | RFC 3620 The TUNNEL Profile |
| 605 | soap-beep | RFC 4227 Using the Simple Object Access Protocol (SOAP) in Blocks Extensible Exchange Protocol (BEEP) |
| 631 | ippipps | RFC 8011 Internet Printing Protocol/1.1: Model and Semantics |
| 647 | dhcp-failover | RFC 8156 DHCPv6 Failover Protocol |
| 700 | epp | RFC 5734 Extensible Provisioning Protocol (EPP) Transport over TCP |
| 701 | lmp | RFC 4204 Link Management Protocol (LMP) |
| 702 | iris-beep | RFC 3983 Using the Internet Registry Information Service (IRIS) over the Blocks Extensible Exchange Protocol (BEEP) |
| 712 | tbrpf | RFC 3684 Topology Dissemination Based on Reverse-Path Forwarding (TBRPF) |
| 714 | iris-xpcs | RFC 4992 XML Pipelining with Chunks for the Internet Registry Information Service |
| 715 | iris-lwz | RFC 4993 A Lightweight UDP Transfer Protocol for the Internet Registry Information Service |
| 716 | pana | RFC 5191 Protocol for Carrying Authentication for Network Access (PANA) |
| 830 | netconf-ssh | RFC 6242 Using the NETCONF Protocol over Secure Shell (SSH) |
| 848 | gdoi | RFC 3547 The Group Domain of Interpretation |
| 853 | domain-s | RFC 7858 Specification for DNS over Transport Layer Security (TLS) RFC 8094 DNS over Datagram Transport Layer Security (DTLS) RFC 9250 DNS over Dedicated QUIC Connections |
| 854 | dlep | RFC 8175 Dynamic Link Exchange Protocol (DLEP) |
| 860 | iscsi | RFC 7143 Internet Small Computer System Interface (iSCSI) Protocol (Consolidated) |
| 861 | owamp-controlowamp-test | RFC 4656 A One-way Active Measurement Protocol (OWAMP) RFC 8545 Well-Known Port Assignments for the One-Way Active Measurement Protocol (OWAMP) and the Two-Way Active Measurement Protocol (TWAMP) |
| 862 | twamp-controltwamp-test | RFC 5357 A Two-Way Active Measurement Protocol (TWAMP) RFC 8545 Well-Known Port Assignments for the One-Way Active Measurement Protocol (OWAMP) and the Two-Way Active Measurement Protocol (TWAMP) |
| 910 | kink | RFC 4430 Kerberized Internet Negotiation of Keys (KINK) |
| 913 | apex-edge | RFC 3340 The Application Exchange Core |
| 914 | rift-lies | RFC 9692 RIFT: Routing in Fat Trees |
| 915 | rift-ties | RFC 9692 RIFT: Routing in Fat Trees |
| 991 | nas | RFC 4707 Netnews Administration System (NAS) |
| 993 | imaps | RFC 3501 INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1 RFC 8314 Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and Access RFC 9051 Internet Message Access Protocol (IMAP) - Version 4rev2 |
| 995 | pop3s | RFC 8314 Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and Access |
| 1001 | webpush | RFC 8030 Generic Event Delivery Using HTTP Push |
| 1021 | exp1 | RFC 4727 Experimental Values In IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP Headers |
| 1022 | exp2 | RFC 4727 Experimental Values In IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP Headers |
| 1027 | 6a44 | RFC 6751 Native IPv6 behind IPv4-to-IPv4 NAT Customer Premises Equipment (6a44) |
| 1038 | mtqp | RFC 3887 Message Tracking Query Protocol |
| 1113 | ltp-deepspace | RFC 5326 Licklider Transmission Protocol - Specification RFC 7122 Datagram Convergence Layers for the Delay- and Disruption-Tolerant Networking (DTN) Bundle Protocol and Licklider Transmission Protocol (LTP) |
| 1118 | sacred | RFC 3767 Securely Available Credentials Protocol |
| 1153 | c1222-acse | RFC 6142 ANSI C12.22, IEEE 1703, and MC12.22 Transport Over IP |
| 1723 | pptp | RFC 2637 Point-to-Point Tunneling Protocol (PPTP) |
| 1812 | radius | RFC 2865 Remote Authentication Dial In User Service (RADIUS) |
| 1813 | radius-acct | RFC 2866 RADIUS Accounting |
| 1847 | slp-notify | RFC 3082 Notification and Subscription for SLP |
| 1985 | hsrp | RFC 2281 Cisco Hot Standby Router Protocol (HSRP) |
| 2049 | nfs | RFC 5665 IANA Considerations for Remote Procedure Call (RPC) Network Identifiers and Universal Address Formats |
| 2083 | radsec | RFC 6614 Transport Layer Security (TLS) Encryption for RADIUS RFC 7360 Datagram Transport Layer Security (DTLS) as a Transport Layer for RADIUS |
| 2142 | tdmoip | RFC 5087 Time Division Multiplexing over IP (TDMoIP) |
| 2268 | amt | RFC 7450 Automatic Multicast Tunneling |
| 2855 | msrp | RFC 4976 Relay Extensions for the Message Sessions Relay Protocol (MSRP) |
| 2905 | m3ua | RFC 4666 Signaling System 7 (SS7) Message Transfer Part 3 (MTP3) - User Adaptation Layer (M3UA) |
| 3205 | isns | RFC 4171 Internet Storage Name Service (iSNS) |
| 3225 | fcip-port | RFC 3821 Fibre Channel Over TCP/IP (FCIP) |
| 3232 | mdtp | RFC 6513 Multicast in MPLS/BGP IP VPNs |
| 3260 | iscsi-target | RFC 7143 Internet Small Computer System Interface (iSCSI) Protocol (Consolidated) |
| 3305 | odette-ftp | RFC 5024 ODETTE File Transfer Protocol 2.0 |
| 3420 | ifcp-port | RFC 4172 iFCP - A Protocol for Internet Fibre Channel Storage Networking |
| 3478 | stunstun-behaviorturn | RFC 5780 NAT Behavior Discovery Using Session Traversal Utilities for NAT (STUN) RFC 8489 Session Traversal Utilities for NAT (STUN) RFC 8656 Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN) |
| 3493 | nut | RFC 9271 Uninterruptible Power Supply (UPS) Management Protocol -- Commands and Responses |
| 3503 | lsp-ping | RFC 8029 Detecting Multiprotocol Label Switched (MPLS) Data-Plane Failures |
| 3544 | teredo | RFC 4380 Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs) |
| 3565 | m2pa | RFC 4165 Signaling System 7 (SS7) Message Transfer Part 2 (MTP2) - User Peer-to-Peer Adaptation Layer (M2PA) |
| 3653 | tsp | RFC 5572 IPv6 Tunnel Broker with the Tunnel Setup Protocol (TSP) |
| 3761 | gsakmp | RFC 4535 GSAKMP: Group Secure Association Key Management Protocol |
| 3784 | bfd-control | RFC 5881 Bidirectional Forwarding Detection (BFD) for IPv4 and IPv6 (Single Hop) |
| 3785 | bfd-echo | RFC 5881 Bidirectional Forwarding Detection (BFD) for IPv4 and IPv6 (Single Hop) |
| 3799 | radius-dynauth | RFC 3576 Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS) |
| 3863 | asap-sctpasap-udp | RFC 5352 Aggregate Server Access Protocol (ASAP) |
| 3864 | asap-sctp-tlsasap-tcp-tls | RFC 5352 Aggregate Server Access Protocol (ASAP) |
| 3868 | diameter | RFC 3588 Diameter Base Protocol |
| 3905 | mupdate | RFC 3656 The Mailbox Update (MUPDATE) Distributed Mailbox Database Protocol |
| 4191 | dsmipv6 | RFC 5555 Mobile IPv6 Support for Dual Stack Hosts and Routers |
| 4321 | rwhois | RFC 2167 Referral Whois (RWhois) Protocol V1.5 |
| 4334 | netconf-ch-ssh | RFC 8071 NETCONF Call Home and RESTCONF Call Home |
| 4335 | netconf-ch-tls | RFC 8071 NETCONF Call Home and RESTCONF Call Home |
| 4336 | restconf-ch-tls | RFC 8071 NETCONF Call Home and RESTCONF Call Home |
| 4341 | lisp-data | RFC 9300 The Locator/ID Separation Protocol (LISP) |
| 4342 | lisp-control | RFC 9301 Locator/ID Separation Protocol (LISP) Control Plane |
| 4460 | ntske | RFC 8915 Network Time Security for the Network Time Protocol |
| 4500 | ipsec-nat-t | RFC 3948 UDP Encapsulation of IPsec ESP Packets RFC 7296 Internet Key Exchange Protocol Version 2 (IKEv2) RFC 9329 TCP Encapsulation of Internet Key Exchange Protocol (IKE) and IPsec Packets |
| 4551 | ieee-mih | RFC 5677 IEEE 802.21 Mobility Services Framework Design (MSFD) |
| 4555 | rsip | RFC 3103 Realm Specific IP: Protocol Specification |
| 4556 | dtn-bundle | RFC 7122 Datagram Convergence Layers for the Delay- and Disruption-Tolerant Networking (DTN) Bundle Protocol and Licklider Transmission Protocol (LTP) RFC 9174 Delay-Tolerant Networking TCP Convergence-Layer Protocol Version 4 |
| 4569 | iax | RFC 5456 IAX: Inter-Asterisk eXchange Version 2 |
| 4590 | rid | RFC 6546 Transport of Real-time Inter-network Defense (RID) Messages over HTTP/TLS |
| 4646 | dots-signal | RFC 8973 DDoS Open Threat Signaling (DOTS) Agent Discovery RFC 9132 Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Specification |
| 4754 | gre-in-udp | RFC 8086 GRE-in-UDP Encapsulation |
| 4755 | gre-udp-dtls | RFC 8086 GRE-in-UDP Encapsulation |
| 4789 | vxlan | RFC 7348 Virtual eXtensible Local Area Network (VXLAN): A Framework for Overlaying Virtualized Layer 2 Networks over Layer 3 Networks |
| 5004 | avt-profile-1 | RFC 3551 RTP Profile for Audio and Video Conferences with Minimal Control RFC 4571 Framing Real-time Transport Protocol (RTP) and RTP Control Protocol (RTCP) Packets over Connection-Oriented Transport RFC 5762 RTP and the Datagram Congestion Control Protocol (DCCP) |
| 5005 | avt-profile-2 | RFC 3551 RTP Profile for Audio and Video Conferences with Minimal Control RFC 4571 Framing Real-time Transport Protocol (RTP) and RTP Control Protocol (RTCP) Packets over Connection-Oriented Transport RFC 5762 RTP and the Datagram Congestion Control Protocol (DCCP) |
| 5060 | sip | RFC 3263 Session Initiation Protocol (SIP): Locating SIP Servers RFC 4168 The Stream Control Transmission Protocol (SCTP) as a Transport for the Session Initiation Protocol (SIP) |
| 5061 | sips | RFC 3263 Session Initiation Protocol (SIP): Locating SIP Servers RFC 4168 The Stream Control Transmission Protocol (SCTP) as a Transport for the Session Initiation Protocol (SIP) |
| 5091 | cxtp | RFC 4065 Instructions for Seamoby and Experimental Mobility Protocol IANA Allocations |
| 5161 | snmpssh | RFC 5592 Secure Shell Transport Model for the Simple Network Management Protocol (SNMP) |
| 5162 | snmpssh-trap | RFC 5592 Secure Shell Transport Model for the Simple Network Management Protocol (SNMP) |
| 5222 | xmpp-client | RFC 6120 Extensible Messaging and Presence Protocol (XMPP): Core |
| 5246 | capwap-control | RFC 5415 Control And Provisioning of Wireless Access Points (CAPWAP) Protocol Specification |
| 5247 | capwap-data | RFC 5415 Control And Provisioning of Wireless Access Points (CAPWAP) Protocol Specification |
| 5269 | xmpp-server | RFC 6120 Extensible Messaging and Presence Protocol (XMPP): Core |
| 5318 | pkix-cmc | RFC 10003 Certificate Management over CMS (CMC): Transport Protocols |
| 5319 | roughtime | RFC 10049 Roughtime: A Protocol for Rough Time Synchronization |
| 5349 | stun-behaviorsstunsturns | RFC 5780 NAT Behavior Discovery Using Session Traversal Utilities for NAT (STUN) RFC 7350 Datagram Transport Layer Security (DTLS) as Transport for Session Traversal Utilities for NAT (STUN) RFC 8489 Session Traversal Utilities for NAT (STUN) RFC 8656 Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN) |
| 5350 | pcp-multicast | RFC 6887 Port Control Protocol (PCP) |
| 5351 | pcp | RFC 6887 Port Control Protocol (PCP) |
| 5352 | dns-llq | RFC 8764 Apple's DNS Long-Lived Queries Protocol |
| 5353 | mdns | RFC 6762 Multicast DNS |
| 5436 | pmip6-cntl | RFC 5844 IPv4 Support for Proxy Mobile IPv6 |
| 5437 | pmip6-data | RFC 5844 IPv4 Support for Proxy Mobile IPv6 |
| 5675 | v5ua | RFC 3807 V5.2-User Adaptation Layer (V5UA) |
| 5683 | coap | RFC 7252 The Constrained Application Protocol (CoAP) RFC 8323 CoAP (Constrained Application Protocol) over TCP, TLS, and WebSockets |
| 5684 | coaps | RFC 7252 The Constrained Application Protocol (CoAP) RFC 7301 Transport Layer Security (TLS) Application-Layer Protocol Negotiation Extension RFC 8323 CoAP (Constrained Application Protocol) over TCP, TLS, and WebSockets |
| 5868 | diameters | RFC 6733 Diameter Base Protocol |
| 5900 | rfb | RFC 6143 The Remote Framebuffer Protocol |
| 6068 | gsmp-ancp | RFC 6320 Protocol for Access Node Control Mechanism in Broadband Networks |
| 6081 | geneve | RFC 8926 Geneve: Generic Network Virtualization Encapsulation |
| 6084 | reload-config | RFC 6940 REsource LOcation And Discovery (RELOAD) Base Protocol |
| 6511 | dccp-udp | RFC 6773 DCCP-UDP: A Datagram Congestion Control Protocol UDP Encapsulation for NAT Traversal |
| 6513 | netconf-tls | RFC 7589 Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 Authentication RFC 9918 Updates to Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 Authentication |
| 6514 | syslog-tls | RFC 5425 Transport Layer Security (TLS) Transport Mapping for Syslog RFC 6012 Datagram Transport Layer Security (DTLS) Transport Mapping for Syslog |
| 6619 | odette-ftps | RFC 5024 ODETTE File Transfer Protocol 2.0 |
| 6635 | mpls-udp | RFC 7510 Encapsulating MPLS in UDP |
| 6636 | mpls-udp-dtls | RFC 7510 Encapsulating MPLS in UDP |
| 6640 | ovsdb | RFC 7047 The Open vSwitch Database Management Protocol |
| 6696 | babel | RFC 8966 The Babel Routing Protocol |
| 6697 | ircs-u | RFC 7194 Default Port for Internet Relay Chat (IRC) via TLS/SSL |
| 6699 | babel-dtls | RFC 8968 Babel Routing Protocol over Datagram Transport Layer Security |
| 6704 | frc-hp | RFC 5811 SCTP-Based Transport Mapping Layer (TML) for the Forwarding and Control Element Separation (ForCES) Protocol |
| 6705 | frc-mp | RFC 5811 SCTP-Based Transport Mapping Layer (TML) for the Forwarding and Control Element Separation (ForCES) Protocol |
| 6706 | frc-lp | RFC 5811 SCTP-Based Transport Mapping Layer (TML) for the Forwarding and Control Element Separation (ForCES) Protocol |
| 6784 | bfd-lag | RFC 7130 Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces |
| 7017 | grasp | RFC 8990 GeneRic Autonomic Signaling Protocol (GRASP) |
| 7563 | cfw | RFC 6230 Media Control Channel Framework |
| 7626 | simco | RFC 4540 NEC's Simple Middlebox Configuration (SIMCO) Protocol Version 3.0 |
| 7744 | raqmon-pdu | RFC 4712 Transport Mappings for Real-time Application Quality-of-Service Monitoring (RAQMON) Protocol Data Unit (PDU) |
| 7784 | s-bfd | RFC 7881 Seamless Bidirectional Forwarding Detection (S-BFD) for IPv4, IPv6, and MPLS |
| 7872 | mipv6tls | RFC 6618 Mobile IPv6 Security Framework Using Transport Layer Security for Communication between the Mobile Node and Home Agent |
| 8060 | aero | RFC 6706 Asymmetric Extended Route Optimization (AERO) |
| 8231 | hncp-udp-port | RFC 7788 Home Networking Control Protocol |
| 8232 | hncp-dtls-port | RFC 7788 Home Networking Control Protocol |
| 8471 | pim-port | RFC 6559 A Reliable Transport Mechanism for PIM |
| 8503 | lsp-self-ping | RFC 7746 Label Switched Path (LSP) Self-Ping |
| 9875 | sapv1 | RFC 2974 Session Announcement Protocol |
| 9878 | kca-service | RFC 6717 kx509 Kerberized Certificate Issuance Protocol in Use in 2012 |
| 9899 | sctp-tunneling | RFC 6951 UDP Encapsulation of Stream Control Transmission Protocol (SCTP) Packets for End-Host to End-Host Communication |
| 9901 | enrp-sctp | RFC 5353 Endpoint Handlespace Redundancy Protocol (ENRP) |
| 9902 | enrp-sctp-tls | RFC 5353 Endpoint Handlespace Redundancy Protocol (ENRP) |
| 9903 | multicast-ping | RFC 6450 Multicast Ping Protocol |
| 10161 | snmpdtlssnmptls | RFC 6353 Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP) |
| 10162 | snmpdtls-trapsnmptls-trap | RFC 6353 Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP) |
| 10500 | hip-nat-t | RFC 5770 Basic Host Identity Protocol (HIP) Extensions for Traversal of Network Address Translators RFC 9028 Native NAT Traversal Mode for the Host Identity Protocol |
| 20049 | nfsrdma | RFC 8267 Network File System (NFS) Upper-Layer Binding to RPC-over-RDMA Version 1 |
| 24601 | udpstp | RFC 9946 The UDP Speed Test Protocol (UDPSTP) for One-Way IP Capacity Metric Measurement |
| 33435 | mtrace | RFC 8487 Mtrace Version 2: Traceroute Facility for IP Multicast |
Other patterns Plain and TLS port pairs · Different services on TCP and UDP · SCTP and DCCP port numbers · Renamed service names · Numbers shared by several services