knownports / Ports 0–99 / Port 21
Port21
ftpFile Transfer Protocol [Control]
IANA has registered port 21 to ftp on TCP, UDP and SCTP. It is one of the 88 numbers with an SCTP entry. The entry cites RFC 959. Its TLS counterpart, ftps, is registered on port 990.
Registry entries
| Service | Protocols | Registered | Modified | RFCs | Other specs |
|---|---|---|---|---|---|
ftp | TCPUDPSCTP | — | Feb 7, 2022 | RFC 959, RFC 9260 | — |
Cited RFCs
| RFC | Title | Published | Status | Later changes |
|---|---|---|---|---|
| RFC 959 | File Transfer Protocol | October 1985 | Internet Standard | updated by RFC 2228, RFC 2640, RFC 2773, RFC 3659, RFC 5797 and 1 more |
| RFC 9260 | Stream Control Transmission Protocol | June 2022 | Proposed Standard | — |
Other names built on ftp
574 ftp-agent 989 ftps-data 3305 odette-ftp 6619 odette-ftps
Listed in Ports that cite an RFC · Plain and TLS port pairs · SCTP and DCCP port numbers